Empty Tables in the Destination
Issue
Tables included in the connector schema are empty in the destination. Relevant data is available in Salesforce.
Environment
Connector: Salesforce
Resolution
To resolve this issue, provide the connecting Salesforce user with the View All permissions on the relevant objects.
NOTE: You must have administrative privileges to set permissions in Salesforce.
Cause
This issue occurs when Salesforce sharing settings prevent the user authenticated with the Fivetran connection from viewing records in the associated object. Providing View All permissions bypasses restrictions caused by sharing settings.