Error: Server Is Not Responding With Correct Response [431]
Issue
Talkdesk syns fail with the following errors:
Server is not responding with correct response after specific retries and giving status code [431]Request Header Fields Too Large
Environment
Connector: Talkdesk
Resolution
To resolve this issue:
- Log in to your Talkdesk account.
- On the navigation menu, select OAuth Clients.
- Locate the OAuth client associated with your Fivetran connection.
- Update the OAuth client to include only the required scopes:
data-reports:writereports:write
- In Fivetran, go to your Talkdesk connection page.
- In the top right, click Sync.
Cause
This issue occurs when the Talkdesk API generates an access token that exceeds the HTTP header size limit for API requests. This may happen when you add too many scopes to the OAuth client, which increases the token size.