Error: The Integration User's Time Zone Is Not GMT/UTC
Issue
When setting up a ServiceNow connection in Fivetran, a setup error occurs:
The integration user's timezone is not GMT/UTC.
Environment
Connector: ServiceNow
Resolution
To resolve this issue:
- Log in to your ServiceNow instance as an administrator.
- Go to the user administration section.
- Find the integration user account that Fivetran uses to connect to ServiceNow.
- Open the user's settings and set the time zone to
GMT/UTC. - Save the changes to apply them.
- In Fivetran, return to the connection setup form and click Save & Test.
If your organization doesn't allow you to change the integration user's time zone, work with your IT or ServiceNow administrator to create a new integration user with the GMT/UTC time zone or update the relevant policy. For more information, see our ServiceNow Setup Guide.
Cause
This issue occurs when the ServiceNow integration user's account uses a time zone other than GMT/UTC. We require this time zone setting to sync timestamp data accurately.