Error: Primary Key employee_employment_status_id Is Null in Object
Issue
Syncs fail with the following error:
Null primary key found while syncing table employee_employment_information. Primary Key employee_employment_status_id is null in object.
Environment
Connector: Ceridian Dayforce
Resolution
To resolve this issue, do the following:
- In Fivetran, go to your Ceridian Dayforce connection page.
- Select the Schema tab.
- Select the checkbox next to the
employee_employment_status_idcolumn in theEMPLOYEE_EMPLOYMENT_INFORMATIONtable. - Click Save changes.
- In Dayforce, enable EmployeeEmploymentStatusId. To learn how, see the Dayforce GET Employee Employment Statuses API documentation.
Cause
The employee_employment_status_id column is the primary key for the EMPLOYEE_EMPLOYMENT_INFORMATION table. This issue occurs when you exclude the column from your connection schema or don't enable EmployeeEmploymentStatusId in Dayforce, resulting in null primary key values.