History Tables Start With an Updated Row Instead of a Creation Row
Issue
In Intercom history tables, the first row should reflect the original state of a record when it was created. However, for some records, the first row shows an updated state, and the creation row is missing.
Environment
Connector: Intercom
Resolution
To resolve this issue, increase your Intercom connection's sync frequency:
- In Fivetran, go to your Intercom connection page.
- Select the Setup tab.
- Update the value in the Sync frequency drop-down menu.
Increasing the sync frequency reduces the likelihood that a record will be both created and updated in Intercom between syncs.
Cause
We replicate the current state of each record at the start of a sync. When you create and update a record in Intercom between syncs, we can only retrieve the updated state. When this happens, we sync the updated version of the record to the history table, and we don't sync the creation row.