Error: Configuration Information Specified Contains Error
Issue
The connection fails with the following error during the initial sync:
Invalid user input was encountered. Configuration information specified in connection settings contains error.
Environment
Connector: Google Campaign Manager 360
Resolution
To resolve this issue:
- Verify the data availability window for the report(s) you want to sync. For more information, see the Google documentation on report data availability.
- In Fivetran, go to your Google Campaign Manager 360 connection page.
- Select the Setup tab.
- Click Edit connection details.
- Open the Historical Sync Time Frame drop-down menu and set a value within the report's data availability range.
- Click Save & Test.
Cause
Google Campaign Manager 360 enforces data retention limits for some reports. If we request data outside the supported availability window, the API returns an error.
During the initial sync, we request data for the historical sync time frame you set. As a result, this issue occurs when this time frame exceeds the report's availability window.