Duplicate Bill Payment Entries Appear in the Transformed QUICKBOOKS__GENERAL_LEDGER Table
Issue
Duplicate bill payment entries appear in the transformed QUICKBOOKS__GENERAL_LEDGER table.
Environment
Connector: QuickBooks
Resolution
To resolve this issue, do the following:
- In QuickBooks, review your chart of accounts.
- Ensure only one Accounts Payable account is active per currency.
- Exclude sub-accounts or inactive accounts if they aren't needed.
The duplicate entries are resolved in the next transformation run.
Cause
This issue occurs when multiple Accounts Payable accounts exist in the same currency. The Fivetran QuickBooks transformation package joins transactions on all active Accounts Payable accounts, resulting in duplicate rows for each active account.