The PREVIOUSTRANSACTIONLINK Table Stops Syncing Daily
Issue
The PREVIOUSTRANSACTIONLINK table unexpectedly stopped syncing daily and now updates only weekly.
Environment
Connector: NetSuite SuiteAnalytics
Resolution
To troubleshoot this issue:
- In Fivetran, go to your NetSuite SuiteAnalytics connection page.
- Select the Schema tab.
- Locate and hover over the
PREVIOUSTRANSACTIONLINKtable. - On the right side of the screen, click Resync.
- In the confirmation pop-up window, click Start re-sync.
If the table's re-import continues to take more than 60 minutes, Fivetran keeps it on a weekly schedule. To sync on a custom schedule instead, use the REST API for custom sync scheduling.
Fivetran does not expose source response time in the UI. You can view overall sync duration in the dashboard, but detailed timing information is only available to the Fivetran Support team through sync logs.
Cause
This issue occurs when the PREVIOUSTRANSACTIONLINK table's full re-import duration exceeds 60 minutes. Fivetran automatically determines the sync frequency for re-import tables based on re-import duration:
| Table re-sync duration | Table re-sync frequency |
|---|---|
| 20 seconds or less | Every sync |
| Between 20 seconds and 60 minutes | Twice a day |
| More than 60 minutes | Once a week |
For more information, see Warning: Not Recommended: This Table Is Not Incremental and Syncs Slowly.