property_hs_* Columns in Engagament Tables Sync as null
Issue
Some property_hs_* columns in engagement tables contain null values.
Environment
Connector: HubSpot
Resolution
To troubleshoot this issue, contact your HubSpot admin. Confirm whether Sensitive Data tools are enabled and whether the affected properties can be made accessible to the integration. If HubSpot continues to restrict access to these properties, Fivetran syncs them as null.
For more information, see the HubSpot CRM Sensitive Data documentation.
Cause
This issue occurs when Sensitive Data tools are enabled in your HubSpot portal. When this happens, HubSpot treats the following engagement properties as sensitive:
hs_body_previewhs_body_preview_htmlhs_email_htmlhs_email_texths_call_bodyhs_meeting_bodyhs_note_bodyhs_task_body
HubSpot encrypts these properties and manages them as sensitive data. Fivetran doesn't sync properties marked as sensitive because we don't have the permission required to read them.