Alert: No Columns Detected for the USER_LIST Table
Issue
In the Schema tab, it's possible to select the USER_LIST table, but the following alert appears:
No columns detected for this table
Environment
Connector: Google Ads
Resolution
To resolve this issue, do the following:
- In Google Ads, verify that you're using a Google Ads manager (MCC) account and that it's linked to the customer account containing the user lists.
- Go to the Audience manager page and confirm that your account contains active user lists.
- In Fivetran, trigger a connection-level re-sync. To learn how, see How to Trigger Historical Re-Syncs for Fivetran Connections.
Cause
The USER_LIST table depends on data from historical tables, such as AD_GROUP_CRITERION_HISTORY and CAMPAIGN_CRITERION_HISTORY. If these underlying tables fall out of sync, we can't fully populate the USER_LIST table. To resolve this, these tables must be re-synced together, which requires a connection-level re-sync.
You may also encounter this alert if your Google Ads account doesn't contain any active user lists.