Error: HTTP 429 Rate Limit Exceeded
Issue
Syncs are delayed, or the initial sync takes longer than expected. The following error appears:
HTTP 429: Rate limit exceeded
Environment
Connector: Genesys
Resolution
To resolve this issue:
- In Fivetran, go to your Genesys connection page.
- Select the Schema tab.
- Deselect any unnecessary tables.
- Click Save changes.
- Pause any other services that consume your Genesys API quota until the initial sync is complete.
- If the issue persists, contact Genesys support to request a higher API quota. For more information, see the Genesys Rate Limits documentation.
Cause
This issue occurs when Genesys Cloud API rate limits restrict the number of API calls we can make. When this happens, we pause and retry after each rate limit error, and sync data to your destination as the API limits allow. Initial syncs can take longer because they load historical data, and rate limits or data complexity can increase the delay.
For more information about Genesys API status codes, see Status Codes.