Conversion Discrepancies in AD_DAILY_REPORT After Changing an Attribution Window
Issue
After updating an attribution window and re-syncing a connection, the AD_DAILY_REPORT table shows higher conversion values in Fivetran than in the Snapchat UI or API. The table also shows non-zero conversion values for ads where the Snapchat UI and API show 0.
Environment
Connector: Snapchat Ads
Resolution
To resolve this issue, do the following:
- In Fivetran, go to your Snapchat Ads connection page.
- Select the Schema tab.
- Find the
AD_DAILY_REPORTtable, then click Re-sync. - In the confirmation pop-up window, click Start re-sync.
As a workaround, use the _fivetran_synced column in your destination to filter out rows synced before the attribution window change.
Cause
The Snapchat API doesn't support deletes. When you change the attribution window, the Snapchat API stops returning some ads. We only update the ads returned by the API, so older records remain in the AD_DAILY_REPORT table with stale conversion data, resulting in inflated conversion totals in Fivetran.