Restored Record in Source Showing As Deleted in the Destination
Issue
A record was deleted from the source and later imported using XML. It is still marked as _fivetran_deleted = true
.
Environment
Connector: ServiceNow
Resolution
To resolve the issue, do the following:
Restore the record from the ServiceNow User Interface (UI).
Re-sync the table.
Cause
We store the last date of deletion for every table and use it as the beginning date.
Once we restore the record in the UI, it is removed from the SYS_AUDIT_DELETE
table.