Why Is the Connector Taking Longer Than Usual to Sync My Data?
Issue
The connector is taking longer than usual to sync my data.
Environment
Connector: Salesforce
Resolution
Search for the resync_table
log event in your logs by either using our free Fivetran Platform connector or external logging services. If there are entries coinciding with the date of the sync, wait for the sync to complete.
Additionally, we recommend that you find what happened within Salesforce that resulted in the purging of its recycle bin.
NOTE: Salesforce purges its recycle bin periodically.
Cause
Salesforce purged its recycle bin before the connector could capture the deletes. If the connector ignores the purge, it introduces a data integrity issue, as we do not know which records are still valid.
We use the getDeleted()
API call to fetch the deleted records for Salesforce tables. If Salesforce has already purged the recycle bin, we have to re-sync these tables.