Error: Couldn't Fetch Columns as Report Size Is Too Large
Issue
A table's primary keys are missing from the Setup tab of the connection page. The following error appears:
Unable to fetch items of type com.fivetran.integrations.workday.WorkdaySetupForm$PrimaryKeys: Couldn't fetch columns from report as report size is too large. Contact Fivetran support to set Primary Keys
Environment
Connector: Workday RaaS
Resolution
To resolve this issue, do the following:
- In your Workday report URL, locate the
Start_Date
andEnd_Date
query parameters. - Specify a shorter time frame by adjusting one or both values.
- In Fivetran, go to your Workday RaaS connection page.
- Select the Setup tab.
- Enter the updated Report URL.
- Click Save & Test.
- Wait for the setup tests to complete.
- If needed, specify a longer time frame and test your connection again.
Cause
This issue occurs when we're unable to load all column data because the report includes too much data for the specified date range.