Records Not Deleted From the OPPORTUNITY_LINE_ITEM
Table
Issue
The OPPORTUNITY_LINE_ITEM
table is not capturing all deletes.
Environment
Connector: Salesforce
Resolution
To resolve this issue, contact our support team to enable re-importing of the OPPORTUNITY_LINE_ITEM
table. This allows us to capture deletes regularly.
For more information on our re-import schedules, see our Salesforce re-import tables documentation.
Cause
Fivetran uses the getDeleted()
call to capture deletes. This call is not reliable for the OPPORTUNITY_LINE_ITEM
table. While most Salesforce tables store the deleted records for 15 days, OpportunityLineItem records are directly deleted. They are not sent to the recycle bin and cannot be recovered. Due to this limitation, the deleted records are sometimes purged from the OPPORTUNITY_LINE_ITEM
table before we capture them.