Records Missing From the TRANSACTION_LINES Table
Issue
Some records in the TRANSACTION table are missing from the TRANSACTION_LINES table.
Environment
Connector: NetSuite SuiteAnalytics
Resolution
You don't need to take action to resolve this issue. Fivetran handles late-arriving NetSuite records using a one-hour rollback window. If a TRANSACTION_LINES record is missing during one sync, the next sync will typically pick it up.
However, to reduce the delay, you can increase your connection's sync frequency:
- In Fivetran, go to your NetSuite SuiteAnalytics connection page.
- Select the Setup tab.
- Update the value in the Sync frequency drop-down menu.
Cause
This issue is due to a known NetSuite behavior. Although TRANSACTION records may appear promptly based on their last_modified timestamp, related TRANSACTION_LINES records may not be immediately available due to delays in NetSuite's internal processing.
We query NetSuite using the expected last_modified range. However, if NetSuite hasn't exposed the corresponding TRANSACTION_LINES records in time, we can't sync them. To ensure data integrity, we re-query one hour before the last synced last_modified timestamp, capturing delayed records during the next sync.