Missing Rows After Disabling Date-Based Filtering in Oracle
Issue
After enabling the Disable Effective Date Filter option in Oracle, Fivetran should sync all records. However, rows are missing from the destination.
Environment
Connector: Oracle Fusion Cloud Applications
Resolution
To ensure we sync all records, regardless of effective start and end dates, you have two options:
- Contact the Oracle support team to report the issue and confirm whether the
isEffectiveDateDisabledparameter is being correctly applied for the affected datastores. - Contact our support team to ensure Oracle’s date-based filtering is disabled. This configuration allows us to extract all available records from the datastores included in your schema, whether or not they fall within the effective date range.
This configuration may significantly increase monthly active rows (MAR) because it includes all records, regardless of their effective dates.
Cause
This issue occurs when the Oracle API doesn't apply the Disable Effective Date Filter setting, even though it's enabled in Oracle. When this happens, the isEffectiveDateDisabled parameter remains set to false. Consequently, Oracle continues to apply date filtering and excludes historical records that fall outside the effective date range.