Data Is Missing From the CUSTOMER_BALANCE_TRANSACTION
Table
Issue
Data is missing from the CUSTOMER_BALANCE_TRANSACTION
table.
Environment
Connector: Stripe
Resolution
To resolve this issue, do the following:
Include the
CUSTOMER
table in your connection schema.i. In Fivetran, go to your Stripe connection page.
ii. Select the Schema tab.
iii. Select the checkbox next to the
CUSTOMER
table.iv. Click Save changes.
Enable the Sync Connected Accounts feature if the missing data is associated with Connected Accounts.
i. Select the Setup tab.
ii. Click Edit connection.
iii. Set the Sync Connected Accounts toggle to ON.
iv. Click Save & Test.
Re-sync the connection.
Cause
The issue may occur due to either of the following reasons:
- The connection schema doesn't include the
CUSTOMER
table, which we depend on for balance transaction data. - The missing data is associated with Connected Accounts, but the Sync Connected Accounts feature isn't enabled.