Data in the TRANSACTION
Table Is Not Updating Correctly
Issue
The data in the TRANSACTION
table is outdated and doesn't match the data I can see in Spotify.
Environment
Connector: Shopify
Resolution
To resolve this issue, you must include the parent table ORDER
in your connector schema. To include the ORDER
table in your existing connector's schema, do the following:
- In your Fivetran dashboard, go to your Shopify connector page.
- Select the Schema tab.
- Check the
ORDER
table check box. - Click Save changes.
Cause
To sync data to the TRANSACTION
table, you must also include the parent table ORDER
in your connector schema. This issue occurs if you include the TRANSACTION
table but don't include the ORDER
table.