Inconsistent Reporting Data
Issue
Why does data in my Apple App Store connector reports differ from the data I see in the App Store dashboard?
Environment
Connector: Apple App Store
Resolution
When comparing API reporting data with the data in your App Store account's dashboard, use the Standard
report type to avoid differences in reporting data.
Cause
Some reports may contain user data. To protect user privacy, the Apple App Store Connect API provides two types of reports:
Standard
, which does not include sensitive fields that potentially contain user data.Detailed
, which includes all fields, and applies threshold and noise measures to help protect uniquely identifiable user data.
Detailed
reports provide values with a small amount of noise, and omit data from values that have fewer than 5 users or 5 unique devices. For example, if a specific row in a report has a true count value of 500,000, then 99.7% of the time the noised count is somewhere between 499,994 and 500,006. In reports with multiple different metrics, these are noised independently.
NOTE: See Apple's anallytics reports documentation for more details.