Error: Cannot Select – User Not Authorized to Access This Table
Issue
Some tables have been removed from the connector's schema. While attempting to re-select the tables, the following error appears:
Cannot select - User not authorized to access this table
Environment
Connector: ServiceNow
Resolution
To resolve this issue, provide us with the appropriate access to the affected tables and all required tables as listed in our ServiceNow prerequisites documentation.
You don't need to take any further action once you have provided the appropriate access. We will automatically include the affected tables in the next sync.
Cause
We remove tables from your schema if we no longer have permission to access them. The above error appears when you attempt to include impacted tables in your connector's schema.