Error: Unable To Connect to API
Issue
While setting up a connector, the following error appears:
Unable to connect to API. Unable to get access token, please reconnect!
Environment
Connector: ServiceNow
Resolution
To resolve this issue, ensure the authenticating user's ServiceNow account can access the ServiceNow API without completing Single Sign-On (SSO) authentication. Alternatively, authenticate the connector with a different ServiceNow account that can access the API without completing SSO authentication.
For more details, see ServiceNow's authentication documentation.
Cause
We require direct access to the ServiceNow API without additional SSO authentication. This issue occurs when you attempt to authorize your connector using an account that requires SSO authentication to access the ServiceNow API.