Error: The Rest API Is Not Enabled for This Organization
Issue
While setting up a connector, the following error appears:
Unable to connect to API. The Rest API is not enabled for this Organization.
Environment
Connector: Salesforce
Resolution
To resolve this issue, do the following:
- Ensure your Salesforce account plan is Enterprise-level or higher or you have purchased Salesforce API calls. For more information, see our Salesforce prerequisites.
- Ensure the authorizing user's Salesforce profile has been granted the
API Enabled
permission. For more information, see Salesforce's Grant API Enabled Access documentation.
Cause
This issue occurs when your Salesforce organization doesn't have access to the Salesforce API or the authorizing user doesn't have permission to contribute to your organization's API quota.