Missing Values for a Custom Field in a Salesforce Object
Issue
Values are missing from a custom field in the destination despite being available in Salesforce.
Environment
Connector: Salesforce
Resolution
To resolve this issue, do the following:
- Confirm the exact name of the Salesforce object containing the custom field.
- Ensure the authorizing user has the necessary permissions to access the custom field. To determine this, check whether the custom field is accessible using a describe call.
- Run a Salesforce Object Query Language (SOQL) query in Salesforce to verify that the custom field contains data.
- If you have made any changes to the authorizing user's permissions, re-sync the affected tables. To learn more, see How to Trigger a Historical Table Re-Sync.
Cause
This issue occurs when the authorizing user doesn't have permission to access the relevant custom field in the Salesforce object.