Manually Updated Values Aren't Reflected in the Destination
Issue
I have manually updated some values in Salesforce, but the values in the destination don't reflect the changes.
Environment
Connector: Salesforce
Resolution
To manually re-sync tables containing out-of-date values, do the following:
- In your Fivetran dashboard, go to your Salesforce connector page.
- In the top right corner, pause the connector by setting the ENABLED toggle to OFF.
- Select the Schema tab.
- Locate and hover over the affected table.
- On the right side of the screen, click Resync.
- In the confirmation pop-up window, click Start re-sync.
- Repeat steps 4 through 6 for each affected table.
- Unpause the connector by setting the ENABLED toggle to ON.
Cause
To detect changes and additions in your Salesforce data, we monitor the following timestamp fields within Salesforce's API responses:
SystemModStamp
LastModifiedDate
CreatedDate
LoginTime
However, manually updating some fields in Salesforce may not cause any of the above fields to update. When this occurs, the values in your destination may not reflect the field values you manually update in Salesforce until you manually re-sync the data or another field change causes one of the timestamp fields to update.