Error: Unable To Connect to API. HTTP 400 Bad Request
Issue
While attempting to connect using a valid Salesforce email address and password, the following error appears:
Unable to connect to API. HTTP 400 Bad Request
Environment
Connector: Pardot
Resolution
To resolve this error, enter your username in the Pardot account email field instead of the email address associated with your account.
Cause
This error appears if you have multiple Salesforce accounts linked to the same email address. When the email address is submitted, Salesforce cannot distinguish accounts. Entering your username instead allows Salesforce to identify the correct account when Fivetran queries the REST API.