Error: Websocket Connection Blocked
Issue
Setup tests fail with either of the following errors:
Websocket connection blocked: A blocked connection can be caused by AdBlocker browser extensions, Antivirus/Firewall software, Proxy/VPN connections, or the Hybrid Deployment Agent not being active.
Encountered an exception due to response code 1000 and message org.apache.http.NoHttpResponseException: xxx.looker.com:443 failed to respond.
Environment
Connector: Looker
Resolution
To resolve this issue, do the following:
- In Fivetran, go to your Looker connector page.
- Select the Setup tab.
- Click Edit connection details.
- Ensure the information provided in the Subdomain field is correct. See step 1 of our Looker setup guide for more information.
- If you must update the Subdomain value, click Save & Test.
- If the Subdomain value is correct, contact our support team.
Cause
This issue occurs when you provide an incorrect Looker subdomain while setting up your connector.