Duplicate Records Appear in the Destination With Different profile_id
Values
Issue
Duplicate records appear in my destination with different profile_id
values.
Environment
Connector: Google Campaign Manager 360
Resolution
To resolve this issue, do the following:
- In the connector dashboard, go to the Setup tab.
- Click Edit connection details.
- Under Sync Mode, select Sync Specific Profile.
- Under User Profiles, deselect unwanted profiles associated with your Campaign Manager account.
All duplicate records previously synced by the connector will remain in the destination. To remove previously synced duplicate records, manually delete them from the destination or exclude them from downstream queries.
Cause
Duplicate records may appear in your destination if you sync multiple profiles associated with the same Google Campaign Manager account. The value of the profile_id
column allows you to determine whether duplicate records originated from different profiles.