Error: Access Token Is Expired
Issue
The following error appears:
Access Token is expired. Please get a new access token { error: {message:'Error validating access token: The session has been invalidated because the user changed their password or Facebook has changed the session for security reasons.', type:'OAuthException', code:190, error_subcode:460, error_user_title:'null', error_user_msg:'null', fbtrace_id:'XXXX'} }
Environment
Connector: Facebook Ads
Resolution
To resolve this issue, do the following:
- From your Facebook Ads connector dashboard, go to the Setup tab.
- Click Edit connection details.
- Select Re-authorize connection.
- Log in with your Facebook user credentials.
- When you are redirected back to Fivetran, click Save & Test.
Cause
This issue occurs when the Facebook access token used to authorize the connection expires or becomes invalid. An access token may become invalid or expired for many reasons, including a change of password or a security concern. For more information about access token errors, see Facebook's documentation.