Why Aren’t All Campaigns Showing Up in My Destination?
Issue
Why aren't all of my Taboola campaigns showing up in my destination?
Environment
Connector: Taboola
Resolution
All API-based connectors sync data that the source allows to collect through their APIs. Our Taboola connector also can sync only the data that we are allowed to collect through Taboola's API. Due to this limitation, not all campaigns are replicated in the destination.
Cause
Fivetran works with Taboola campaigns in the following ways:
- Data from the terminated campaigns cannot be pulled using the Taboola API. Once the status of the campaign changes to
terminated
, it does not appear in the resource list from the API. - Fivetran syncs campaign data from the day the sync started to date. This means, if a campaign’s
start date
is set to a date in the future, Fivetran won't be able to sync that campaign.
For more information, see Taboola's API documentation.