Tables Are Missing From the Connector Schema
Issue
Tables are missing from the connector schema.
Environment
Connector: Oracle Business Intelligence Publisher
Resolution
To resolve this issue, check whether the affected tables exist in the FND_TABLES
table in your source by running the following SQL query:
SELECT TABLE_NAME, APPLICATION_SHORT_NAME FROM FUSION.FND_TABLES WHERE TABLE_NAME = '<table_name>'
If the missing tables don't exist in the FND_TABLES
table, we don't sync them. You can create a feature request to add support for the missing table. If the tables exist in the FND_TABLES
table, run the following SQL query to check whether they're active:
SELECT TABLE_NAME, APPLICATION_SHORT_NAME FROM FUSION.FND_TABLES WHERE select_allowed = 'Y' and status = 'Active' and TABLE_NAME = '<table_name>'
If the output from the above query doesn't include the affected tables, they are either inactive or can't be selected. Ask your Oracle Business Intelligence Publisher Administrator to update the relevant settings for each table, then do the following:
- In your Fivetran dashboard, go to your Oracle Business Intelligence Publisher connector page.
- Select the Schema tab.
- Click the Reload schema button.
- Check that the affected tables now appear in the connector schema.
- Click SYNC NOW or wait until your connector's next scheduled sync occurs.
Cause
This issue occurs when a table is missing from the FND_TABLES
table, inactive, or can't be selected.