Tables Are Missing From the Schema Config
Issue
A table cannot be found in the schema config.
Environment
- Connector: NetSuite SuiteAnalytics
- Data source: NetSuite.com
Cause
A potential cause of a table not being found in the schema config, and not syncing, is the table is only available with certain roles. If the NetSuite user has not been configured with the required role, the table won't be available to sync by the connector.
See NetSuite Roles Documentation to understand what roles are required per table.
In NetSuite, a user can have multiple roles. It may be that the authenticated user needs to be additionally assigned one of the roles that give access to Location.
Resolution
- Verify that the roles that are assigned to the user authenticated with the connector will allow for the sync of your required table.
- Update these as needed and the table will become available in the connector schema configuration.