The username
and email
Columns in the USER
Table Are null
Issue
The username
and email
columns in the USER
table contain null
values.
Environment
Connector: Jira
Resolution
Connectors Using OAuth Authentication
To resolve this issue, each Jira user in your organization must do the following:
- In Jira, go to the Profile and visibility page.
- Locate the Email address and Username fields.
- Adjust the visibility setting to
Anyone
.
See Jira's profile and visibility documentation for more information.
Connectors Using Basic Authentication
If one cannot change the visibility setting to Anyone
, use Basic Authentication and adjust the visibility setting to your Organization's name.
Cause
For GDPR compliance purposes, Atlassian restricts user data visibility based on user profile privacy settings. See Atlassian's Deprecation notice and migration guide for more information.