Error: 403 Access Denied
Issue
Connector syncs fail with the following error:
403 access denied.
Syncs are successful when I re-enter the API key. However, after 24 hours, the syncs fail again with the same error.
Environment
Connector: Freshdesk
Resolution
Ensure that the API key you used to complete your Fivetran configuration is associated with a Freshdesk Full-time agent rather than an Occasional agent. For more information on agent roles, see Freshdesk's documentation.
Cause
Freshdesk Occasional agents must use a Day Pass each time they access your Freshdesk account. If an Occasional agent has not logged into your Freshdesk account in the last 24 hours, the agent will no longer have an active Day Pass. As a result, Fivetran will no longer have access to your API.