Error: We Could Not Sync Data for the Following Accounts
Issue
While setting up a new connector, the setup test fails with the following error:
We could not sync data for the following accounts.
Environment
Facebook Ads and Instagram Business connectors.
NOTE: Facebook Ads and Instagram Business connectors share the same API account retrieval and authentication process.
Resolution
To resolve this issue, do the following:
- Create a new Facebook system user.
- Assign the necessary permissions to the new user.
- Assign only the affected Facebook or Instagram accounts to the new user.
- Create a new Fivetran connector using the new system user credentials to authenticate the connector.
NOTE: If you create the new connector through the API, use an access token generated for the new system user.
Cause
This error appears when too many source accounts are associated with the connecting user.