Some custom_field
Columns Contain null
Values
Issue
custom_field
data is available in the Coupa API's endpoint responses. However, the relevant data is missing from the custom_field
column in the destination.
Environment
Connector: Coupa
Resolution
To resolve this issue, ensure the Coupa API returns the relevant custom_field
data as a nested object under the <custom-fields>
parent element in the API response rather than at the top (root) level.
To do this, go to the relevant custom field in Coupa and deselect the API Global Namespace checkbox. For more information, see Coupa's Custom Field Namespace documentation.
Cause
The Coupa API can return custom_field
data as a top-level (root) field or nested under the <custom-fields>
parent element. To sync custom_field
data to your destination, we require that it is nested under <custom-fields>
.
In addition, Coupa doesn't support custom data for all API endpoints. If the relevant custom_field
data is not present in the API, we can't sync it, even if it's available in Coupa.
As a result, this issue may occur for either of the following reasons:
- The Coupa API returns the relevant
custom_field
data as a top-level field. - The API does not provide
custom_field
data for the requested endpoint.