Error: Unable to Connect to App Store Connect API Due to Missing or Expired Agreement
Issue
While setting up a connection, the following error appears:
Unable to connect to App Store Connect API. Unable to connect to API due to a required agreement that is missing or has expired. This request requires an in-effect agreement that has not been signed or has expired.
Environment
Connector: Apple App Store
Resolution
To resolve this issue, do the following:
Log in to your Apple App Store Connect account.
Go to the Agreements, Tax, and Banking section.
Review the list of agreements. Accept any marked as pending or expired.
If you don’t have the permission required to accept agreements, contact an Apple Admin user.
In Fivetran, save and test your connection.
If the issue persists:
i. Confirm that your Apple API credentials are valid.
ii. Check for service disruptions on the Apple System Status page.
iii. Contact our support team with relevant details, such as error messages and screenshots.
Cause
This issue occurs when a required Apple App Store agreement is missing or has expired.