Error: We Couldn't Sync Primary Endpoint(s)
Issue
Syncs fail with the following error:
We couldn't sync 6 out of the 16 primary endpoint(s). We were unable to sync data for the following tables: [ACADEMY_AWARDED_CERTIFICATION, ACADEMY_CERTIFICATION, ACADEMY_USER_CUSTOM_REGISTRATION, ACADEMY_USER, ACADEMY_PATH_USER, ACADEMY_REGISTRATION, ACADEMY_USER_SEGMENT, ACADEMY_PATH_USER_CUSTOM_REGISTRATION, ACADEMY_TRAINING]
Environment
Connector: WorkRamp
Resolution
To resolve this issue, do the following:
- In Fivetran, go to your WorkRamp connector page.
- Select the Setup tab.
- Click Edit connection details.
- In the Academy ID field, ensure you have provided the correct academy ID. To find your academy ID, see step 1 of our WorkRamp setup guide.
- Click Save & Test.
Alternatively, you can leave the Academy ID field blank in your connector setup form. However, if you don't provide an academy ID, you must avoid syncing ACADEMY_*
tables by doing the following.
- Select the Schema tab.
- Uncheck the
ACADEMY_*
tables. - Click Save changes.
Cause
This issue occurs when you provide an incorrect or invalid academy ID in your connector setup form and include ACADEMY_*
tables in your connector schema.