Error: Disk Cache Error. Field Length: 4000000 Exceeds Maximum Limit of 65535
Issue
The connector fails with the following error:
Error updating table: <TABLE NAME> java.sql.SQLException:
\[NetSuite\]\[SuiteAnalytics Connect JDBC Driver\]\[OpenAccess SDK SQL Engine\]
Disk cache error. Field length:4000000 exceeds maximum limit of 65535.\[10232\]
Environment
Connector: NetSuite SuiteAnalytics
Resolution
Solution 1: Disable the table
- Access the connector dashboard.
- Click on the Schema tab.
- Filter for the table containing the problematic column.
- Select the checkbox next to the table to disable it.
- Save the schema changes.
Solution 2: Truncate the problematic column
Log in to the NetSuite source.
Run the following query to isolate the problematic column. Replace anything in
<>
with the correct value.SELECT COUNT(*) from ""<SCHEMA>"".<TABLE> WHERE LENGTH(<COLUMN_NAME>) > 65535;
Truncate the column so it no longer exceeds the limit.
Cause
One of the columns in the table referenced in the error has data greater than the limit supported by the JDBC driver.