Error: Unable to Access Selected Accounts
Issue
Connector setup tests fail. The following error appears:
Unable to access selected accounts
Environment
Connector: Microsoft Advertising
Resolution
To resolve this issue, do the following:
Ensure your Microsoft Advertising credentials are active and valid, and you can access the relevant account.
Log out of your Microsoft Advertising account.
In an Incognito window, re-authorize the connection.
i. In Fivetran, go to your Microsoft Advertising connection page.
ii. Select the Setup tab.
iii. Click Edit connection.
iv. Click Re-Authorize Connection and ensure you provide the correct credentials.
v. Click Save & Test.
Cause
This issue may occur due to one of the following reasons:
- The authorizing user's credentials are invalid or incorrect.
- The OAuth token associated with the connection has expired or been revoked, possibly due to a password reset.