Error: Cannot Select – Not Available in Your HubSpot Subscription
Issue
It's not possible to select some tables in the schema configuration. The following error appears:
Cannot select - Not available in your HubSpot subscription.
Environment
Connector: HubSpot
Resolution
To resolve this issue, provide Super Admin access to the HubSpot user authenticated with the connector. See our setup guide for more information.
Cause
This issue occurs when an error is returned while querying the applicable table endpoint in the HubSpot API. We provide the following warning in the connector logs:
"{"event":"warning","data":{"type":"not\_enough\_permission","message":
"Do not have enough permissions to sync deal table,
if the table is checked in schema it will be unchecked."}