Error: Cannot Fetch ID From Phone Number
Issue
Setup tests fail. The following error appears:
Unable to connect to API. Cannot fetch ID from phone number. Make sure the phone number is registered in Apple as trusted phone number.
Environment
Connector: Apple App Store
Resolution
To resolve this issue, do the following:
Find Fivetran-managed phone number
- In Fivetran, go to your Apple App Store connector page.
- Select the Setup tab.
- Click Edit connection.
- Make a note of the Phone Number.
Add phone number as a trusted device
- Go to your Apple dashboard and sign in to your Fivetran-dedicated Apple account.
- Click Account Security.
- Click the plus icon to add a new trusted phone number.
- In the phone number field, enter the phone number you found in step 1.
- Select Text message, then click Continue.
Get verification code
- Return to the connector setup form and click get verification code to receive the verification code.
- Make a note of the verification code.
Verify Fivetran-managed phone number
- Return to your Apple ID account page.
- Use the verification code you obtained to verify the trusted phone number.
- Click Verify.
Cause
This issue may occur due to either of the following reasons:
- The Fivetran-managed phone number associated with your connector hasn't been added to your Fivetran-dedicated Apple account correctly or has been deleted.
- You have changed the password associated with your Fivetran-dedicated Apple account.