Error: F_JT0905: Log Start Positioning Error F_JZ1101: Capture Job Unable To Locate File Sequence
Issue
Archive logs were recovered to a non-original Oracle Automatic Storage Management (ASM) folder. Capture cannot scan the recovery archive logs. The following errors appear:
F_JT0905: Log start positioning error
F_JZ1101: Capture job unable to locate file sequence for resetlogs_id in thread 1 which corresponds to hvrinit time.
Environment
- HVR 6
- Oracle Automatic Storage Management (ASM) with files stored in a fast recovery area (FRA) structure.
Resolution
To resolve this issue, do the following:
- Move the recovery archive logs in the new ASM folder to a file system directory.
- Modify the location to include the following properties:
- Capture_Method with the value ARCHIVE_ONLY.
- Archive_Log_Path
- Archive_Log_Format according to the archive logs.
- Activate the channel.
You can query the system tables V$ARCHIVED_LOG and V$LOGFILE to determine the expected locations (physical or ASM) of files associated with the quoted file SEQUENCE and RESETLOGS_ID.
Cause
The following are the reasons that result in the above errors:
- The archive logs may not have been recovered into their original Oracle ASM folder.
- The archive log settings may have generated archive log file names in a different format than before, and Capture attempts to use the new file name.