The first_reply_time_business_minutes Metric Excludes Replies From Deactivated Agents
Issue
The Zendesk ticket metric first_reply_time_business_minutes does not match the data in Zendesk. It appears to exclude replies from deactivated agents.
Environment
Transformations: Zendesk dbt Package
Resolution
To resolve this issue:
Upgrade the Fivetran Zendesk dbt package to version 0.23.0 or later. For more information, see Package Maintenance.
Include the
AUDIT_LOGtable in your connection schema:i. In Fivetran, go to the relevant Zendesk Support connection page.
ii. Select the Schema tab.
iii. Select the checkbox next to the
AUDIT_LOGtable.iv. Click Save changes.
After the next sync completes, Quickstart uses this data going forward.
Cause
Versions of the Fivetran Zendesk dbt package earlier than 0.23.0 do not use reconstructed historical role data for this calculation. In version 0.23.0, we introduced support for reconstructing role history from the AUDIT_LOG table. For more information, see the Fivetran Zendesk dbt package v0.23.0 release notes.