Capture Shows Empty Cycles Despite Active Database
Issue
Your database is active, but Capture shows empty capture cycles with no rows captured. The issue persists when you suspend and restart Capture or re-activate the channel with the Jobs and Table Enrollment options selected.
Environment
- HVR 6
- Source database: PostgreSQL
Resolution
To resolve this issue, do the following:
- Check how far back HVR rewinds when you re-activate the channel.
- If it rewinds too far, go to step 2.
- If it does not rewind too far, contact our support team.
- Run Activate Replication with the following options selected:
- Jobs
- Table Enrollment
- Capture Time and Transaction Files with the Capture Start Moment option set to No Rewind into DBMS logging stream.
- Run Refresh for the affected tables.
This resets the capture replication slot and brings the data up to sync.
Cause
This issue occurs when we rewind too far and can't find the transaction in your source database. When this happens, we don't encounter an error, but we also can't capture rows.