Error: Application Identifier (Entity ID) Already Exists
Issue
While setting up single sign-on (SSO) with Microsoft Entra ID, the following error appears:
Application identifier (Entity ID) already exists
Environment
- Account Settings
- SSO
- Identity provider: Microsoft Entra ID
Resolution
Microsoft Entity ID allows only one instance of the Fivetran Microsoft Entra ID gallery application for each tenant. To configure SSO for multiple Fivetran accounts, you must use separate enterprise applications:
- Use the Fivetran gallery app for one account. This provides default SAML settings for faster setup.
- For more information, see our Add Fivetran application setup instructions.
- Add a custom SAML app for each additional account.
- Assign a unique Entity ID and reply URL to prevent conflicts.
Cause
Microsoft Entra ID requires each SAML application to have a unique Entity ID. However, when you try to configure more than one Fivetran gallery app in the same tenant, they all use the same default Entity ID, resulting in the above error.