Error: TCP/IP Connection to the Host Has Failed
Issue
While setting up an Azure SQL Managed Instance database as a destination in Fivetran, the following error appears:
The TCP/IP connection to the host <subdomain>.<subdomain>.<region>.worker.database.windows.net (redirected from 127.0.0.1/localhost), port 1433 has failed.
Environment
Destination: Azure SQL Server Managed Instance
Resolution
To resolve this issue, change the connection type of your Azure SQL Server Managed Instance from Redirect to Proxy:
- In the Azure Portal, go to your Azure SQL Managed Instance settings.
- Select Networking.
- Under Connection Policy, change the connection type from Redirect to Proxy.
- Save the changes.
- Ensure your firewall rules allow the required Fivetran IP addresses and TCP traffic on port
1433. - In Fivetran, run the destination setup tests again.
For more information on configuring the connection type, see the Microsoft Azure SQL Managed Instance connection types documentation.
Cause
This issue occurs when the Azure SQL Managed Instance uses the Redirect connection type, which we don't support for destination connections. The Proxy connection type ensure traffic is routed correctly.