Error: Login Failed for User
Issue
Setup tests fail. The following error appears:
Login failed for user. ClientConnectionId:xxx
Environment
The following SQL Server database connectors:
- Generic SQL Server
- Amazon RDS for SQL Server
- Azure SQL Database
- Azure SQL Managed Instance
- Google Cloud SQL for SQL Server
Resolution
To resolve this issue, ensure the following:
- The information you provide in the setup form's User and Password fields is correct and the User field value is correctly formatted.
- The authorizing user has the permission required to connect the database to Fivetran.
- The authorizing user is not locked out of their account or required to reset their password.
For information on how to format the value in the User field and the required permissions, see the applicable setup guide for your SQL Server database:
- Generic SQL Server
- Amazon RDS for SQL Server
- Azure SQL Database
- Azure SQL Managed Instance
- Google Cloud SQL for SQL Server
Cause
This issue may occur for any of the following reasons:
- You provided an incorrect username or password in the setup form's User or Password fields, or formatted the User field value incorrectly.
- You don't have the permission required to connect the database to Fivetran.
- You are locked out of your SQL Server database instance or must reset your password.