Error: Error in Open SSH Channel
Issue
The connector fails. The following error appears:
Error in ssh channel
Environment
Connector: High-Volume Agent SQL Server
Resolution
To resolve this issue, do the following:
In SQL Server, disable or set the maximum value for login and query timeouts.
- Disable the remote login timeout by setting the
remote login timeout
value to0
. For more information, see Microsoft's Configure the remote login timeout documentation. - Disable the remote query timeout by setting the
remote query timeout
value to0
. For more information, see Microsoft's Configure the remote query timeout documentation. - Set the
query wait
value to the maximum value of2147483647
. For more information, see Microsoft's Configure the query wait documentation.
- Disable the remote login timeout by setting the
Perform a historical re-sync.
i. In Fivetran, go to your High-Volume Agent SQL Server connector page.
ii. Select the Setup tab.
iii. Click Resync all historical data.
iv. In the confirmation pop-up window, click Re-sync Connector.
NOTE: Contact our support team if you encounter errors while performing the historical re-sync.
Find your connector's sync duration.
i. Wait for your sync to complete.
ii. On your Fivetran connector page, select the Status tab.
iii. In the Sync History chart, hover over the most recent green sync bar, representing the most recent successful sync.
iv. Make a note of the Entire Sync Duration value.
Update your SQL Server
remote login timeout
,remote query timeout
, andquery wait
values to correspond with the Entire Sync Duration value you found in step 3.
Cause
This issue occurs when your SQL Server instance's timeout settings prevent us from completing a sync.